//SOLVED// Push notifications stopped after new phone upgrade
3 3

19 posts in this topic

Hello all. I need assistance please. My old iPhone went to MAC heaven and I upgraded to the new iPhone 7. When I downloaded the app my push notifications stopped. I checked my notifications permissions for Iris and it was configured correctly but my new device was NOT listed in the Iris app under "manage your notifications". I deleted the old iPhone, but now it won't pickup my new phone. I tried everything. Deleted the app and reinstalled it.. turned the phone off then on... logged out, then back in... I'm out of options.. how can I get the app to recognize my new phone?

I should also include that I am receiving email messages instead of push notifications. The rule is set to push messages..

post-5450-0-92050400-1478231709_thumb.png

Share this post


Link to post
Share on other sites

When you installed the app on your new phone did it recognize all your devices you have on your system?  You should have also received an email stating a new device has been added to your account.

Share this post


Link to post
Share on other sites

Thanks for the reply.

All devices are recognized but I did not get an email. I did get an email when I removed old phone. I have logged out and uninstalled... then reinstalled and logged in and no luck. It still emails me the notifications and not pushes as instrucinbthe rules.

Share this post


Link to post
Share on other sites

Hmmm... now I'm not sure what's going on.  According to the pop-up message in the screenshot below you should start receiving push notifications when you log into the device.  You might want to try logging out of the app and then do a 2 second reboot on your hub.  After your hub is back up with a solid green light, log back into your app and check your push notification list to see if your iPhone is listed.

 

post-122-0-25984000-1478318447_thumb.png

Share this post


Link to post
Share on other sites

I'm having the same issue after upgrading my phone as well.  I had push notifications working on 3 different devices, an iPad, iPhone, and an Android Tablet.  I removed the old phone from the notifications list and tried reinstalling the application on my new phone however it never shows up in the Push Notification list and I don't get notifications on it.  I'm wondering if one of the newer application updates broke this or if there is some way to add a device, I never remember adding the others so I think it happened when I signed in the first time however I cannot get this new phone to do it no matter how many times I logoff and back on or uninstall and reinstall then logon to the app and reset the cards and photos.  Has anyone else with this issue gotten it to work?

Share this post


Link to post
Share on other sites

Just installed my first Iris system and am having the same problem with iPhone -- no push notifications and the phone does not show up in the Iris app.  Called tech support twice.  First time they told me this was a known issue with the latest IOS.  Second time they told me there was no known issue and that logging in/out, resetting the hub, etc should solve the problem, though it may take 12 hours to start working.  But still nothing...  

Share this post


Link to post
Share on other sites

Yeah, I rebooted the hub last night after everything else I tried (more than 12 hours ago) I then logged out/in after that as well and still nothing.  I'm hoping the next application release will correct this if the first tech you talked to said it was a known issue with a recent iOS version.

Share this post


Link to post
Share on other sites

Spoke with Iris tech support again.  They confirmed that there is indeed an issue with iOS push notifications.  They said is was caused by Apple's latest update, which affected other apps besides Iris and there is nothing Iris can do.  They expect Apple to release a new upgrade within the next week to fix the issue.

Share this post


Link to post
Share on other sites

Push notifications still not working for me.  Tried an older iOS device, not working there either.  Just wondering whether they are working for anyone?

Share this post


Link to post
Share on other sites

I recently updated my iPhone 5S to an iPhone 7 and have not had any issues with push notifications working on the new phone.  The big difference between my update process and the OP is my phone did not die.  I was able to back up my old phone in iTunes and then ran a restore process on my new phone.  After the restore process completed I removed the sim card from the old phone and installed it in the new one and the only thing I had to do with Iris is log back into the app.  

 

When I logged in I received an email from Iris stating "A new mobile device was used to sign into your Iris account."

 

****Update.... As a test I reset my old iPhone and set it up as a new phone and then installed the Iris app.  When I logged into the app I did not receive the email that a new device was used and push notifications are not working on my old phone. I also noticed that the old phone is not listed under Settings | Profile | Push Notifications.

 

This is definitely a bug that needs to be addressed.

Share this post


Link to post
Share on other sites

Upgraded to new IPhone 7 and same thing happening to me. I have tried everything! This is a very important issue! Can Iris please confirm that you are working on this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
3 3