How to Take Total Control of your Iris Cameras with the API
16 16

214 posts in this topic

Update - took better part of the day to unravel 4 cameras, had to turn off the electric and un plug LAN and bring them into the router one at a time, had to reset one, that was twisted up with a different IP-Mac address combo.

That also incuded power down reset on the router,

 

I've noticed some come up with a bigger picture, any obvious reason?

 

Now off to Blue Iris to figure out port forwarding to get these to read on their APP.

 

 

Share this post


Link to post
Share on other sites
13 hours ago, C2LS7driver said:

I've noticed some come up with a bigger picture, any obvious reason?

Now off to Blue Iris to figure out port forwarding to get these to read on their APP.

The the image size is controlled by the resolution.  Use /adm/get_group.cgi?group=H264 to see what yours are set at.

Port forwarding is never a good idea unless you are using something like sTunnel or VPN.

https://www.youtube.com/watch?v=_FkZ3pw6W4I&t=21s

Using a VPN is a much better option.

Share this post


Link to post
Share on other sites

I followed the instructions for both best resolution possible, how do I know what this means:

[H264]
mode=1
resolution=4
quality_type=1
quality_level=3
bit_rate=4000
frame_rate=5
gov_length=10
sp_uri=
mode2=1
resolution2=4
quality_type2=1
quality_level2=3
bit_rate2=1000
frame_rate2=30
gov_length2=10
sp_uri2=
mode3=0
resolution3=3
quality_type3=1
quality_level3=3
bit_rate3=1000
frame_rate3=30
gov_length3=10
sp_uri3=
profile=66
cropping=0
profile2=66
cropping2=0
profile3=66
cropping3=0

 

this is #66 and its good

[H264]
mode=1
resolution=4
quality_type=1
quality_level=3
bit_rate=4000
frame_rate=5
gov_length=10
sp_uri=
mode2=1
resolution2=4
quality_type2=1
quality_level2=3
bit_rate2=1000
frame_rate2=30
gov_length2=10
sp_uri2=
mode3=0
resolution3=3
quality_type3=1
quality_level3=3
bit_rate3=1000
frame_rate3=30
gov_length3=10
sp_uri3=
profile=66
cropping=0
profile2=66
cropping2=0
profile3=66
cropping3=0

 

this is #86 and it is not:

[H264]
mode=1
resolution=4
quality_type=1
quality_level=3
bit_rate=2000
frame_rate=5
gov_length=30
sp_uri=
profile=77
mode2=1
resolution2=4
quality_type2=1
quality_level2=3
bit_rate2=1000
frame_rate2=30
gov_length2=30
sp_uri2=
profile2=77
mode3=0
resolution3=3
quality_type3=1
quality_level3=3
bit_rate3=1000
frame_rate3=30
gov_length3=30
sp_uri3=
profile3=77
bandwidth=0
cropping=0
bandwidth2=0
cropping2=0
bandwidth3=0
cropping3=0

 

Share this post


Link to post
Share on other sites

You might want to read through this:  https://github.com/edent/Sercomm-API/blob/master/README.md

I would suggest you change your bit and frame rates.

Here's what I'm using:

[H264]
mode=1
resolution=4
quality_type=0
quality_level=3
bit_rate=7
frame_rate=15
gov_length=10
sp_uri=
profile=66
mode2=1
resolution2=4
quality_type2=0
quality_level2=3
bit_rate2=7
frame_rate2=15
gov_length2=10
sp_uri2=
profile2=66
mode3=0
resolution3=3
quality_type3=1
quality_level3=3
bit_rate3=1000
frame_rate3=30
gov_length3=30
sp_uri3=
profile3=77
bandwidth=0
cropping=0
bandwidth2=0
cropping2=0
bandwidth3=0
cropping3=0

Share this post


Link to post
Share on other sites

The settings I posted are a matter of personal preference which I found to provide a balance between image quality and wifi bandwidth usage.  You can decide what works best for your needs.  Here's the configuration file specs:

SerComm Neutral Brand IP Camera Configuration File ... - Rpra.co.uk (1).pdfSerComm Neutral Brand IP Camera Configuration File ... - Rpra.co.uk (1).pdf

Share this post


Link to post
Share on other sites
On 3/19/2017 at 9:23 PM, Vettester said:

I've been able to get audio through Blue Iris, but it has a lot of static.  If you listen real close you can hear what's going on, but with all the static it's not very useful.  Anyone else able to get a clear audio stream?

I ran this command on my Iris cameras ( /adm/set_group.cgi?group=AUDIO&audio_in=1 ) however I've not been able to get audio to stream through Blue Iris, do you remember the settings you used for this?  I know it was a long time ago and you may not have any on your system anymore.  I'm trying to setup my Iris cameras for my parents since they wanted some outdoor cameras.  Thanks!

Share this post


Link to post
Share on other sites
4 minutes ago, Terk said:

I ran this command on my Iris cameras ( /adm/set_group.cgi?group=AUDIO&audio_in=1 ) however I've not been able to get audio to stream through Blue Iris, do you remember the settings you used for this?  I know it was a long time ago and you may not have any on your system anymore.  I'm trying to setup my Iris cameras for my parents since they wanted some outdoor cameras.  Thanks!

Here's my audio out settings for the Iris camera:

[AUDIO]
audio_in=1
in_volume=1
in_audio_type=1
audio_out=1
out_volume=8
out_audio_type=0
audio_mode=1
operation_mode=1
au_trigger_en=0
au_trigger_volume=50
au_trigger_method=0
in_pcm_sr=8000
audio_in2=1
in_pcm_sr2=5512
in_audio_type2=3

And here's how I have it configured in Blue Iris:

Camera Config.PNG

Audio.PNG

Share this post


Link to post
Share on other sites

I think it worked, I'm not home to make a noise to see how it sounds but after changing the video settings in BI like yours I get static when I crank the volume while watching the live feed were before it would be completely silent.

Thanks.

Share this post


Link to post
Share on other sites

Yeah I get static with my clip playback now.  Did you ever play around with the time_stamp option?  I tried to set the camera to get its time from my BI server and tried adding the VIDEO&time_stamp=1 option but don't see a timestamp on the stream, trying to have a timestamp on the video but without having to use overlays in BI so I can turn on direct to disk.

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
16 16