Lock unlocking for no reason
1 1

21 posts in this topic

I am pretty sure I have seen someone say something about this, but today one of my locks has unlocked itself twice for no reason.  All the history says is unlocked.  There is no one home and I have a camera that would have recorded if someone had opened the door.  I also have motion detectors that would have alerted me, so no one is there to physically unlock it.   So it had to have been unlocked remotely.  Only me and my wife can do that, other than Iris.  I am assuming my wife didn't and I am afraid to ask her.  If she finds out locks are opening on their own I may have to ditch the whole thing.

 

Perhaps as a feature request Iris should give more detail on who unlocked a lock.  If you use a code it tells you whose code, but that is it.  Perhaps telling you whose account was used to open, if done with the app could be useful info.

Share this post


Link to post
Share on other sites

I am pretty sure I have seen someone say something about this, but today one of my locks has unlocked itself twice for no reason.  All the history says is unlocked.  There is no one home and I have a camera that would have recorded if someone had opened the door.  I also have motion detectors that would have alerted me, so no one is there to physically unlock it.   So it had to have been unlocked remotely.  Only me and my wife can do that, other than Iris.  I am assuming my wife didn't and I am afraid to ask her.  If she finds out locks are opening on their own I may have to ditch the whole thing.

 

Perhaps as a feature request Iris should give more detail on who unlocked a lock.  If you use a code it tells you whose code, but that is it.  Perhaps telling you whose account was used to open, if done with the app could be useful info.

 

Do you have an away scene that locks doors when you leave?  Is there any chance that the doors were unlocked when you left with the expectation that the away scene would lock them for you, yet did not?

Share this post


Link to post
Share on other sites

I use the rule that locks a door if the alarm is set while the door is unlocked.
My wife would leave and lock the door behind her and shortly after the away rule runs (which is also supposed to lock the doors) I would get an alert saying that the deadbolt was locking because the alarm was set and it was unlocked.
Sometimes I would specifically leave from lunch and lock the door, and look for the alert when I got about 10 minutes up the road. Almost every time, I would get an alert that said it was locking because the alarm armed and the door was not locked... even though I specifically locked the door and waited to see what would happen when it realized I left.
I got the feeling the part of the away scene which was supposed to lock the door was actually unlocking if it was already locked... then a couple seconds later the alarm sets and triggers the rule that lockes the doors because the alarm was set.
I just took the door locking action out of my away scene and never had a problem after that.... until a couple of days ago... I showed my wife an alert that said the doors automatically locked because she forgot to lock them.
She swears she did not forget and specifically remembered locking it behind her... who knows...
 

Share this post


Link to post
Share on other sites

Mine did this last week in the middle of the night at my business.  No explanation, it just did.  

 

Then yesterday (I initially thought it was today) it stopped logging who came and went, but it did lock and unlock appropriately. 

 

It is listing itself as connected in the APP on my Android Phone.  Haven't checked it on the ipad yet. 

Share this post


Link to post
Share on other sites

I use the rule that locks a door if the alarm is set while the door is unlocked.

My wife would leave and lock the door behind her and shortly after the away rule runs (which is also supposed to lock the doors) I would get an alert saying that the deadbolt was locking because the alarm was set and it was unlocked.

Sometimes I would specifically leave from lunch and lock the door, and look for the alert when I got about 10 minutes up the road. Almost every time, I would get an alert that said it was locking because the alarm armed and the door was not locked... even though I specifically locked the door and waited to see what would happen when it realized I left.

I got the feeling the part of the away scene which was supposed to lock the door was actually unlocking if it was already locked... then a couple seconds later the alarm sets and triggers the rule that lockes the doors because the alarm was set.

I just took the door locking action out of my away scene and never had a problem after that.... until a couple of days ago... I showed my wife an alert that said the doors automatically locked because she forgot to lock them.

She swears she did not forget and specifically remembered locking it behind her... who knows...

 

 

Any chance the deadbolt could be "jamming"?  On my Smart Things system at home I have a deadbolt that will have a little more friction closing in certain positions which will trigger it to send out a "jammed" signal to the ST hub.  Then I get an alert that says the lock jammed.  (The bolt is out, just not fully engaged)  Does this type of reporting happen on Iris? 

Share this post


Link to post
Share on other sites

Do you have an away scene that locks doors when you leave?  Is there any chance that the doors were unlocked when you left with the expectation that the away scene would lock them for you, yet did not?

From going back through the history I believe that is what happened.  Normally when I go in the shop I lock the door when I shut it, but I noticed from looking at the history this morning I did not.  After I got the bike out of the shop I ran the away scene, which should have locked the shop since I had forgotten.  From the history I can see it was unlocked when I ran the scene..  It was already unlocked so it really did not change.   I just got a message that it unlocked  This message appeared within a minute of running the scene.

 

My wife came home a little later to pick something up and when she left she ran the away scene again.  The shop lock was still unlocked at this point, since it never locked when I left.  The history then shows the lock as unlocked again.  The message appeared in the history almost 30 minutes later, however.  I have three locks and all three appeared in the history after running the away scene.   The first appeared in the history within a minute of running the scene, the second about 20 minutes later and the third about 10 minutes after the second. 

 

The third one was the one that said it was unlocked, which was it's state at the time of running the scene.  The first two were locked already when the scene was ran, I verified via the history.

 

So it sounds like depending on Iris to lock via a scene is iffy.  I guess I have never noticed before because we generally lock the doors manually as we leave.  I just added them to the scene just in case we forget.

Share this post


Link to post
Share on other sites

From going back through the history I believe that is what happened.  Normally when I go in the shop I lock the door when I shut it, but I noticed from looking at the history this morning I did not.  After I got the bike out of the shop I ran the away scene, which should have locked the shop since I had forgotten.  From the history I can see it was unlocked when I ran the scene..  It was already unlocked so it really did not change.   I just got a message that it unlocked  This message appeared within a minute of running the scene.

 

My wife came home a little later to pick something up and when she left she ran the away scene again.  The shop lock was still unlocked at this point, since it never locked when I left.  The history then shows the lock as unlocked again.  The message appeared in the history almost 30 minutes later, however.  I have three locks and all three appeared in the history after running the away scene.   The first appeared in the history within a minute of running the scene, the second about 20 minutes later and the third about 10 minutes after the second. 

 

The third one was the one that said it was unlocked, which was it's state at the time of running the scene.  The first two were locked already when the scene was ran, I verified via the history.

 

So it sounds like depending on Iris to lock via a scene is iffy.  I guess I have never noticed before because we generally lock the doors manually as we leave.  I just added them to the scene just in case we forget.

 

Thank you.  Your response is very helpful.  

Share this post


Link to post
Share on other sites

I was able to duplicate this just now.  I unlocked the shop door and then ran the away scene.  30 minutes later I got a message saying my shop door was unlocked.   It never locked as it should.

 

I have two away scenes, one has fewer devices than the other.  I first tried the other one and it seemed to work fine.  That scene is ran if one of us is still home, All that scene does is lock doors, shut garage doors and turn off outside lights.  The away scene that did not lock the door does the same as the other except it also shuts off all lights and receptacles inside the house.

Share this post


Link to post
Share on other sites

Any chance the deadbolt could be "jamming"?  On my Smart Things system at home I have a deadbolt that will have a little more friction closing in certain positions which will trigger it to send out a "jammed" signal to the ST hub.  Then I get an alert that says the lock jammed.  (The bolt is out, just not fully engaged)  Does this type of reporting happen on Iris? 

No, I'm having a problem with a lever lock doing this and they don't jam.

Share this post


Link to post
Share on other sites

Any chance the deadbolt could be "jamming"?  On my Smart Things system at home I have a deadbolt that will have a little more friction closing in certain positions which will trigger it to send out a "jammed" signal to the ST hub.  Then I get an alert that says the lock jammed.  (The bolt is out, just not fully engaged)  Does this type of reporting happen on Iris? 

No, I would leave for lunch and lock the door behind me... watching for the green check to appear on the deadbolt to ensure it locked properly.

Then I'd get down the road and it would tell me it locked because the alarm set while the door was unlocked. Pretty much every time.

Share this post


Link to post
Share on other sites

It seems that if your doors are locked when the away scene runs this problem is rare.  If I unlock several of my doors and run the away scene the doors rarely lock.  Try unlocking all your doors if you have several locks.  Pin your away scene to favorites and run it.  See if all of your locks lock.  Let us know what happens.

Share this post


Link to post
Share on other sites

Just tested my other away scene and got similar results.  I unlocked all three of my doors and then ran the shorter away scene.  My Kwickset lock and the lock in the shop, Schlage, locked immediately.  The one in the shop is the one I thought had unlocked twice by itself in the first post.  My front door lock, Schlage, never did lock and after about 20 minutes I got a message saying it unlocked.  A couple of times during that wait I looked with the app to see what it showed and when I would open the device it would not show if it was locked or unlocked.    Both buttons on the lock device page were dim and neither could be selected.

Share this post


Link to post
Share on other sites

It seems that if your doors are locked when the away scene runs this problem is rare.  If I unlock several of my doors and run the away scene the doors rarely lock.  Try unlocking all your doors if you have several locks.  Pin your away scene to favorites and run it.  See if all of your locks lock.  Let us know what happens.

 

I only have two locks and every time I run the away scene they both lock.

Share this post


Link to post
Share on other sites

Just tested my other away scene and got similar results.  I unlocked all three of my doors and then ran the shorter away scene.  My Kwickset lock and the lock in the shop, Schlage, locked immediately.  The one in the shop is the one I thought had unlocked twice by itself in the first post.  My front door lock, Schlage, never did lock and after about 20 minutes I got a message saying it unlocked.  A couple of times during that wait I looked with the app to see what it showed and when I would open the device it would not show if it was locked or unlocked.    Both buttons on the lock device page were dim and neither could be selected.

 

This is the exact behavior I see and it is very random.  Sometimes some lock but not others.  I just tried it again and none locked.  On Friday when I tested it 2 locked but not the others.  There is certainly a bug here.

Share this post


Link to post
Share on other sites

Just had this happen again yesterday.  When I got home from work, I came in the front door, which I normally don't do, there were some packages delivered. 

 

I was carrying boxes when I came through the door so I forgot to lock it  A bit later we went to the grocery store and I ran my away scene when we left.   While walking around the grocery store, about 20 minutes later, with my wife I got a notification that my front door unlocked. 

 

It is a bit disconcerting to get that when you know no one is home.   It took a second and then I realized what had happened and locked the door with the app.  They really need to get this fixed.

Share this post


Link to post
Share on other sites

I believe this is happening with the GDOs as well.  I haven't tested it, I keep forgetting when I am at home to try it, but several times when I run my away scene one of my GDO's won't close. I end up closing it manually, but I will notice many times I get a message 20 or so minutes later stating it closed.  This has been happening for quite some time, I always just assumed it was taking that long for it to finally send the command to close it.  I bet if I left it open I would get the same message I get for the lock that it opened. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

1 1