Pairing GE 12727

3 posts in this topic

I have just purchased a GE 12727 in wall switch.  Since the most available controller was the Iris, I decided to try this.  So far, I have been unable to get the controller/hub to recognize the switch.  The switch is installed according to the GE instructions, including a neutral connection.  I first tried following the instructions on the Iris app and when it didn't pair, have repeated it several dozen times.  This was at a distance of about 40 feet.  Next, I moved controller right next to the switch using a 50 foot Ethernet cable.  Still nothing.

I have also tried removing the switch from the network, but there is nothing to remove!

I have no idea how to remedy this.

Share this post

Link to post
Share on other sites

I'm assuming you didn't hear the triple beep for pairing success?

- When you toggle on/off the switch, does the internal relay click (checks for proper installation)?

Try your "Remove from network" procedure again - it could be that the switch needs to be reset:

- In the IRIS App, go to the Devices page

- At the very bottom is a button called "ZWave Tools"

- Select "Remove Z-Wave Devices", then select the button of the same name

- Once in that mode, move the installed switch to the "off" position, and it should trigger two beeps from the hub.  The app should probably show something like "Unknown switch" or something but that's ok since it was never paired

- Get out of the Remove Z-wave mode in your app.  Reset your hub by holding the reset button (small button next to the Ethernet cable) for about 2 seconds.  Hub should respond with a long beep.  After the hub illuminates a solid green light, try your re-pair process again

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now